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Introduction

ApplicationXtender (AX) clients include:

o Document Manager client is used to create, annotate, index, and retrieve documents.

¢ Image Capture client is used for bulk scanning where the users can scan paper documents
to create batches that can be opened using the Document Manager client.

Target audience: Staff who uses Banner INB and need AX tools to view, scan, and/ or index
documents.

How to request/ access
Request
The Data Security Designate has to submit the webform (Request access to AX) to grant access for

those who require the AX clients via RD (RemoteApp and Desktop) Web Access or installed on
their computer.

Access

¢ AX Clients(Document Manager and Image Capture client) can be

o Used Via RD (RemoteApp and Desktop) Web Access. For more details,
see ApplicationXtender tools via RD Web Access

o Installed on your computer

Sign in to ApplicationXtender clients from your computer

Note: if you would like to have the AX clients install on your computer, you will need ask a Data
Security Designates in your department/unit to submit the webform (Request access to AX) and
provide a reason why you need AX clients to be installed on your computer.

1. Once AX clients are installed on your computer, open Document Manager.
2. Sign in with your *Banner UserID and password.

*Banner INB UserlID and Banner Password:for more information, go
to http://kb.mcgill.ca/it/easylink/article.html?id=1001
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Sign in to ApplicationXtender tools via RD Web Access

For details on the sign-in procedure, choose the instruction set based on your computer operating system:

Windows

e RD Web Access to Banner INB and ApplicationXtender tools (for ALL users)
e Start menu for RD Web Access to Banner INB and ApplicationXtender Tools (for IT-managed computers)

Mac OS
e MS Remote Desktop setup for Banner INB and ApplicationXtender Tools
Note: once you have logged into the RD Web Access, choose one the following ApplicationXtender tools icons:

B Work Resources

— ’j' RemoteApp and Desktop Connecti

RemoteApp and Desktops

Current folder: /A-Banner INB Prod

Jf/‘ A A
Up ApplicationX... ApplicationX...
Document Image
Manager Prod  Capture Prod
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Workstation settings

Make sure that 044-ISR AX-Accounts (AX service accounts) are allowed to logon locally and that
you are able to “Impersonate a client”. This should be done by the System Administrator when AX
is installed, but if you have any issues accessing the AX database, you can verify the settings as

follows:

1. Go to Start > Administrative Tools > Local Security Policy

[§ Desktop Gadget Gallery

w FreeMind

€ Geogle Chrome

& Internet Explorer

@ Mozilla Firefox

_' Windows DVD Maker

2 Windows Fax and Scan

[3] Windows Media Player
- Windows Update

<4 XPS Viewer

Accessories

Administrative Tools

. Adobe LiveCycle ES2
Alertus Technologies

Adobe Design and Web Premium
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Local Security Policy

Computer -
P Performance Monitor

Print M £
Control Panel nnt Vlanagemen

Devices and Printers s Services
| System Configuration

-) Task Scheduler

) Wl

Default Programs

Administrative Tools »

Remote Server Administration Tools

Windows Firewall with Advanced Secur
(3] Windows Memory Diagnostic

View
and a3

elp and Support

Run...

FShutdown | ¥ |
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2. Go to Local Policies > User Rights Assignment > Allow log on locally; click Add User or
Group and enter 044-ISR AX-Accounts if it isn’t there; click OK to add it.

File Action View Help
3 2EXE = HE

T Security Settings Policy Security Setting 2
& Account Policies

4 [ g Local Policies
>[4 Audit Poli

| Access Credential Manager as a trusted caller
1) Access this computer from the network Everyone Administrators...
1] Act as part of the operating system

|

User Rights Assignment % 7
Secoriy Options 2« Add workstations to domain
~| Windows Firewall with Advanced Sec| Adjustaasmasy quatastons process EOCAL SERVICE NETWO . =
< Network List Manager Policies 1 Allow log on locally Guest, Administrators,Ba... 3
== Public Key Policies [ Allow log on through Remote Desktop Services Administrators,Remote ...
| Software Restriction Policies 1) Back up files and directories Administrators,Backup ...

| Application Control Policies [ Bypass traverse ¢ Allow log on locally Properties e =

8, 1P Security Policies on Local Compute|| </ Change the systs
1 Advanced Audit Policy Configuration|| /] Change the timg | | Local Securty Setting | Explain |

x| Creste 2 pagehig j' Allow log on locally

12 Create a token o

lis) Create global obj -~
[l Create permaney Select Users, Computers, Service Accounts, or Groups L m

l1ly| Create symbolic|

| Debug program Administrators Select this object type:

53 Deny access to gi‘;g‘p Operatol | sers, Service Accourts, Groups, or Buitn securty principals
1 Deny log on as g From this location:
1) Deny log on as 3 campus.megill.ca
5 Deny log on loc

Enterthe object names to select Il

1 Deny log on thrg
Enable commnite Tm“SR AxcAccourts| | Check Names
—

/li.; and applications”
For more information, see Allow log on locally. (3823659)

3. Go to Local Policies > User Rights Assignment > Impersonate a client after authentication;
if your name is not listed, click Add User or Group.

3 Local Security Policy
I[ File Action View Help
=5 2EXE =0
& S?CU’itY Settings Policy = Security Setting
‘5 fccolu;tl??lmes iy Enable computer and user accounts to be trusted for delega...
4La ?CZ d?tl‘c)lel% 72| Force shutdown from a remote system Administrators
A _OICY - .. Generate security audits LOCAL SERVICE,N
v | A User Rights Assignr] - — —
- - - Lt Impersonate a client after authentication LOCAL SERVICE,N
b 4 Security Options || ke —
> ] Windows Firewall with || "1 Impersonate a client after authentication Properties m
| Network List Manager || “
| Public Key Policies Local Security Setting Explain[
| Software Restriction Pc|| 4 " I e
i | Application Control Po|| :i! PREmnAe AN 3 el
&, 1P Security Policies on | | =]
| Advanced Audit Policy|| 4
< N Administrators
d| | |LOCAL SERVICE
3 NETWORK SERVICE
2} SERVICE
lowe) M
| |
IR
hk ||
oo} YN
R | | Remove
7| pr—rT— " L Add User or Group... J Remove
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4. Enter your McGill Username (first.last@mcgill.ca) or an Active Directory group to which
you belong in the textbox and click OK.

Impersonate a client after authentication Properties ‘ @ R |

Local Security Setting | Explain |

Impersonate a client after authentication

Administrators

LOCAL SERVICE
NETWORK SERVICE
SERVICE

A Useroreoup...T

P
Select Users, Computers, Service Accounts, or Groups

Select this object type:

Users, Service Accounts, Groups, or Builtin security principals
From this location:

campus.mcgill.ca

Locations.
Enter the object names to select (examples):
last@mcaill cal Check Names
o
Advanced... [ ok || cancel ]
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First time users: Before logging into Document Manager

Make BANNER.MCGILL.CA your default Data Source:

1. Go to Start > All Programs > ApplicationXtender Desktop > Data Source Selector.
2. Double-click on BANNER.MCGILL.CA in the list, or select it and click Set as Default;

g2 AppXtender Data Source Selector

]
Data Source Name | Description | Locate... I
] BANNERMCGILL.CA Upgiaded 04 instance

Refresh

0K |  Cancel |(—j
N
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Document Manager - Application view

When you enter the Document Manager for the first time, you don’t see the application view. To

view the application window:

1. Launch Document Manager:
o From Banner INBOR

o Directly from your Windows Desktop (click Start > ApplicationXtender Desktop >

Document Manager)

. ApplicationXtender Desktop
Data Source Selector

R
2o Document Manager

ﬁ- Image fLapture

When launching from the desktop, you will be prompted to log in with your McGill Short

Username and Banner/AX Password.

2. If the window is empty, click the View menu and select Applications.

&

4 ApplicationXtender Document Manager

" Status Bar

= % QB

Toolbars

File Edit | Documnent Page 5Scan  Annoctate
O : Applications
: Cuery
Thumbnail

7
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You will now see the applications that you have access to.

-ﬂ‘ ApplicationXtender Document Manager

File Edit VYiew Document Page S5Scan  Annotate Utilities Window

[ER opphes 2@ s> » DB E
|#» -BHOEGSRLLLARS= B & -0 H
_J123455?39101112131415151?18

|
=4 &7 QBAN1.MCGILL.CA "
m-I2) B-F-DOCS - BANNER FINANCE PURCHASING / AP

..... [ B-F-GRNT - BANNER FINANCE GRANT

..... [ B-F-ID - BANNER FINANCE COMMON

..... [ B-F-PROP - BANNER FINANCE PROPOSAL

-2 B-G-1D - BANNER COMMON

..... [ B-H-APPL - BANNER HR APPLICANT

@I B-H-EMPL - BANNER HR EMPLOYEE

E-I25] B-H-POSN - BANMER HR POSITION

E-I3) B-5-ADMMN - BANNER STUDENT ADMISSIONS

..... == B-5-CRSE - BANNER STUDENT COURSE / ID

..... [ B-5-DGRE - BANNER STUDENT DEGREE

@I B-5-1D - BANNER STUDENT COMMON

..... [ B-5-SECT - BANNER CATALOG / COURSE SECTION

F-I25) M-G-SEC - MCGILL BANNER SECURITY

F-I5] M-G-TEST - DUMMY APP USED TO TEST CLIENT INSTALLS
B3 M-H-PEN - MCGILL PENSION APPLICATION v
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Document Manager - Query View

1. From the View menu, select Query.

-ﬂ‘ Applicationitender Document Manager

File Edity Wiew | Document Page S5Scan  Annotate |

JJE 7 Applications | 44 2

JJ - Query = =

EUSSN— Thumbnail .

JJ 1 2 »"  Status Bar ﬂ
Teolbars »

Query window

%| (2 Search | =] Resut Set: 0]
Fields Values

D
PIDM
DOCUMENT TYPE [
LAST NAME
FIRST NAME
55N

(e Options
’7 Shuwlall documents ;I [ Include Previous Document Revision Search I Save |

For Help, press F1 |]
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Document Manager - Index View

1. Loginto Document Manager.
2. Select the application containing the batch for indexing from the left app view.

[#-I2] M-G-TEST - DUMMY APP USED TO TEST CLIENT INSTALLS

3. Click Utilities > Batch Index (List)...

u Utilities  |Window Help

] Batch Index (List). Ctrl+B
Batch Index (Single)...
Batch Import... Ctrl+ M

Batch Create...
Fax-in Batch Create...
Export Link File Content...

Rernowve Retention Holds
l

4. Select a batch and click Index.

Batch Index
Batches for application: | M-G-TEST ﬂ Indes |

REE | Page | Tirne Starnp | Created By | Status = Cancel
bdrms_wtatia - 1045, 1 20151005 21:08.. BDMS_WTATIA Ide |:|
bdms_wtatia - 1048... 1 20151008 22:44... BDMS_WTATIA  Idle N Delete
bdrmis_wtatia - 1244... 1 201512050118, BOMS_WTATIA  Idle
FMTEST BATCH ... 2 20151007 13:56... BDMS_KHMIM.. bemo
FKNTEST-MOWZE 1 2015-11-2610:39...  BDMS_KNIM...  Idle
rvtest 7 AN1RA012 1541 RMkS PWER Idl= i
' 1 [ » Help

5. Select Document > Batch Index > New Document.

FF51  McGill IT Customer Services Document Manager — Index View
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ender Document Manager
Document | Page Scan  Annotate Utilities Window Help
Page Pon BB E|E S

Previous Page PgUp v oM *~ 3 ~ A M
Go To Page... Ctrl+G

MNext

B 17 18 19 20
:!

~

Mew ¥

Delete
Duplicate Document Ctrl+F5

Check In...
Check Qut...
Cancel Check Qut

Index >

QOCR
M Auto OCR

Thumbnails

LA

i Export >
e Print...
Print PDF Document...

Mail Document Pages...

R
= Mail Reference...

Submit Full Text Index Jab
Submit OCR Job

Mew Document > Ctrl+MN
M Copy or Move Pages ST

m Attach All Pages Ctrl+A
L Classify and Transfer...

- File for Retention...

Place Retention Hold...

N

5. Fields and names of indexing fields will be shown.

DOCUMENT TYPE |=0[=ES
COMMENT
ACTIVITY DATE  |20151214 125652
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Document Manager - Script View

When you first log into Document Manager, you see the script view (shown below).

& ApplicationXtender Document Manager
File Edit View Document Page Scan Annotate LUtilities Window Help

oz erhe s 2BH > DEBE S5
#-BHIHSPRAPNARSSEANR-OF-T -0
1 2 3 4 5 6 7 8 9 1011121314156 16 1718 19 20

1) B-H-EMPL - BANNER HR EMPLOYEE -~
-1 B-H-POSN - BANNER HR POSITION
[#I2) B-5-ADMN - BANNER STUDENT ADMISSIONS
{7 B-5-CRSE - BANNER STUDENT COURSE / ID
-7 B-5-DGRE - BANNER STUDENT DEGREE
[#I3) B-5-ID - BANNER STUDENT COMMON
-2 B-5-5ECT - BANNER CATALOG / COURSE SECTION

P USED TO TEST CLIENT INSTALLS
I M-H-PEN - MCGILL PENSION APPLICATION
I M-R-GIA - GRANT IMAGE APPLICATION
I3 M-5-KRDXTRAN - MCGILL ARCHIVED TRANSCRIPTS
I3 M-5-5R - STUDENT RECORDS
I M-5-SR-MP - POST GRAD MED STUDENT RECORDS
|2 M-T-EBILLING - ACCOUNTS RECEIVABLE (E-BILLINGS)
|2 M-T-STUDACCT - STUDENT ACCOUNTS
-2 _RSTAMP - RUBBER STAMP APPLICATION w

This view is not used. To disable this view, click View > Toolbars and click on Script.

ﬁ ApplicationXtender Document Manager
File Edit Document  Page  Scan  Annctate  Utilities  Window
Applications |M)||I| =] %
|| 5 - Bl Quey SSEX-0H
e Thumbnail
|1 2 Status Bar » 13 14 15 16 17 18 |
-3 Annotation
Full Text Results
[]...[ﬁ e
-1 Rotate Left
..... = )
= Rotate Right Ctrl+R Batch Index
& Zoom > Scan
----- =
T No Split v Small lcons
[]...[ﬁl Split Horizontally Large lcons
&I Split Vertically 1ON
e |
..... ] Scale-To-Gray ANSCRIPTS
""" = Sticky View >
B0 [ RECORDS
..... | Form Overlay > C(E-BILLINGS)
----- i OCR Text ‘
""" = Document Index > M ¥
2| D Se=  Full Screen F11
I

The script view will now disappear.
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AX Power Users - switching between environments

By default AX Desktop Suite is configured to point to PROD (BANNER) environment. Some Power
Users will be required to work with other environments, such as BANQA.

To switch to a specific environment:

1. In Windows Explorer, go to your local folder: C:\ProgramData (Note: you may have totype
C:\ProgramData into the address bar of Windows in order to see that folder)

2. |Ifthereis already a file named xscm.config, rename it to xscm.config.LOCAL (this will be a
backup)
3. Open another Windows Explorer window and navigate to this folder on the network:
\\Campus\Deptshare\BanVol1\Apps\AX7.0Setup\XSCM-Config

4. Copy all contents of this folder into C:\ProgramData

5. In C:\ProgramData, double click on the appropriate .bat file for the environment you want to
access (DEV: switchToDEV.bat, QA : switchToQA.bat, PROD : switchToPROD.bat )

6. Launch the Data Source selector as usual and follow the normal process.

—
@U{x « Local Disk (C:) » ProgramData |§v [ +9 Wl Search

File Edit View Tools Helb "
Organize v Include in library « Share with v Bumn New folder
4 ¥¢ Favorites Name Date modified
Bl Desktop &) switchToDEV.bat 10/14/201510:44 ..,
& Downloi = | [&) switchToPROD.bat 10/14/2015 10:45
. RecentF 3 switchToQA.bat 10/14/2015 10:45
& XSCM.CONFIG 10/29/2015 12:02
4 9 Libraries __| XSCM.CONFIG.LOCAL 10/13/2015 1:53 PM
| Docume & XSCM.CONFIG.PROD 10/13/2015 4:37 PM
o Music ] XSCM.CONFIG.QA 10/13/2015 1:43 PM
& Pictures - J
- Subversi _ =
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Image Capture - Application view

First time users do not see the application view as shown below.

File Edit View Batch Page Scan  Annotate Window Help
[Xl@lsealr)DER|SS|
EREFEEEEEEREE]
Bslesal HIHM M e -8-18-%

To view the application window:

1. Launch AX Desktop > Image Capture.
2. From the menu, click View > Applications.

File Edit 'U'inv Batch Page Scan  Annotate  Wing

JJ|_| il v Applications

JJS?TEf'ftatmﬁar M
Toolbars r
53 11T
JJ Rotate Left Ctrl+L
= &2 UBJ Rotate Right Ctrl+R

You will now see the applications.
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Image Capture - Patch List View

1. Right click on the application you want to view and select Batch List...

[AFP ULl 10 ETTTR
:N Mew Batch,.,

8 Batch List..

;1

C Froperties

L4,

i Set &z Active Spplication
ISR IT & ™) IR T |

The Batch list will appear.

Troubleshooting

If you see error messages from the web browser or within the AX Desktop application, refer to
the IT Knowledge Base — search for “Banner Imaging (ApplicationXtender)”.

If you need assistance resolving the errors, please contact the IT Service Desk at 514-398-3398
or email ITSupport@mcgill.ca.
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